Basic Part Modeling

MEEG 202 Lab Session

This modeling process includes sketching and creating bosses, cuts and fillets.
**Part Setup**

1. **New part**
   
   Click File, New, Part

2. **Select the sketch plane**
   
   Insert a new sketch and choose the Top Plane

   **Tip:** A plane doesn’t have to be shown in order to be used; it can be selected from the Feature Manager.

---

**Sketching the First Feature**

3. **Sketch a rectangle**
   
   On the Sketch toolbar, click rectangle and begin the rectangle making sure it is linked at the origin. Do not worry about the size of the rectangle; dimensioning will take care of this.

![Figure 1](image1.png)

4. **Fully Define the Sketch**
   
   Add dimensions to the sketch using the smart dimension feature located under the sketch tab of the command manager (Note: All units are in inches).

![Figure 2](image2.png)

**Note:** Upon successful completion the sketch will be fully defined (shown above in Figure 2 with all sketch lines appearing black and in the notification panel stating “Fully Defined” at the bottom right of the screen).
Understanding Extruding

An explanation of some of the more frequently used Extrude options is given below:

- **End Condition Type**
  A sketch can be extruded in one or two directions. Either or both directions can terminate at some blind depth, up to some geometry in the model, or extend through the whole model.

- **Depth**
  The distance for a blind or mid-plane extrusion. For mid-plane, it refers to the total depth of the extrusion. That would mean that a depth of 50mm for a mid-plane extrusion would result in 25mm on each side of the sketch plane.

- **Draft**
  Applies draft to the extrusion. Draft on the extrusion can be inwards (the profile gets smaller as it extrudes) or outward.

5. **Extrude**

On the features tab of the command manager click the extrude Boss/Base Feature and extrude the rectangle 0.5" upward.

6. **Renaming Features**

Any feature that appears in the Feature Manager Design tree (aside from the part itself) can be renamed. Renaming features is a useful technique for finding and editing features in later stages of the model.

It is good practice to rename the features that you create with some meaningful name. In the Feature Manager Design tree, use a very slow double-click to edit the feature Extrude 1. When the name is highlighted and editable, type `BasePlate` as the new feature name. All features in the Solid Works system can be edited in the same way. Instead of using a slow double-click to edit the name, you can select the name and press F2.
Boss Feature

The next feature will be the boss with a curved top. The sketch plane for this feature is not an existing reference plane but a planar face of the model. The required sketch geometry is shown overlaid on the finished model. Cut features are created in the same way as bosses — with a sketch and extrusion. They remove material rather than add it.

Tip: Cut features are created in the same way as bosses with a sketch and extrusion. They remove material rather than add it.

7. Insert New Sketch

Create a new sketch using **Insert, Sketch** or by clicking the Sketch tool and select the indicated face (Figure 6).

Advance Sketching

SolidWorks offers a rich variety of sketch tools for creating profile geometry. In this example Tangent Arc is used to create an arc that begins tangent to a selected point on the sketch. Its other endpoint can be placed in space or on another sketch entity. **Insert Tangent Arc** is used to create tangent arcs must be tangent to some other entity, line or arc, at its start.

- From the Tools menu, select Sketch Entity, Tangent Arc
- Or, on the Sketch tab in the command manager click Tangent Arc

Tangent Arc Intent Zones and Auto-Transitioning (Lines and Arcs)

When you sketch a tangent arc, the Solid Works software infers from the motion of the cursor whether you want a tangent or normal arc. There are four intent zones, with eight possible results as shown. You can start sketching a tangent arc from the end point of any existing sketch entity (line, arc, spline, and soon). Move the cursor away from the end point.

- Moving the cursor in a tangent direction creates one of the four tangent arc possibilities
- Moving the cursor in a normal direction creates one of the four normal arc possibilities
- A preview shows what type of arc you are sketching
- You can change from one to the other by returning the cursor to the endpoint and moving away in a different direction

When using the Line tool, you can switch from sketching a line to sketching a tangent arc, and back again, without selecting the Tangent Arc tool. You can do this by moving the cursor as described above, or by pressing the A key on the keyboard.
8. **Vertical line**

Click the line tool and start the vertical line at the lower edge capturing a coincident relation at the lower edge and a vertical relation for the line. (Figure 8)

9. **Auto-Transition**

Press the letter A on the keyboard. You are now in tangent arc mode.

10. **Tangent arc**

Sketch an 180° arc tangent to the vertical line. Look for the inference line indicating that the end point of the arc is aligned horizontally with the arc’s center.

When you finish sketching the tangent arc, the sketch tool automatically switches back to the line tool. (Figure 9)

11. **Finishing lines**

Create a vertical line from the arc end to the base, and one more line connecting the bottom ends of the two vertical lines. Note that the horizontal line is black but its endpoints are not.

12. **Add dimensions**

Add linear and radial dimensions to the sketch. As you add the dimensions, move the cursor around to view different possible orientations.

Always dimension to an arc by selecting on its circumference, rather than center. This makes other dimensioning options (min and max) available.
13. Extrude direction

Click Insert, Boss, Extrude and set the Depth to 0.5”. Note that the preview shows the extrusion going into the base, in the proper direction.

If the direction of the preview is away from the base, click the Reverse direction button.

14. Completed Boss

The boss merges with the previous base to form a single solid. Rename the feature VertBoss.

View Orientation

View Orientation is used to display the model from many different angles while working. If you want, you can click on the push pin" icon and keep the dialog box tacked on the screen at all times.

- From the View menu, choose Orientation....
- Or, right click on the graphic window and click the View Orientation tool
- Or, use the keyboard shortcut by pressing the Spacebar

15. Change the View Orientation

Press the spacebar and double-click *Isometric from the list.

Using the Hole Wizard

The Hole Wizard is used to create specialized holes in a solid; it can create simple, tapered, counterbored and countersunk holes using a step by step procedure. In this example, the Hole Wizard will be used to create a counter bored hole.

You can choose the face to insert the hole onto and then define the hole’s dimensions using the Hole Wizard. During the process you can also position the hole’s location on the face. One of the most intuitive aspects of the Hole Wizard is that you specify the size of the hole by the fastener that goes into it.

Tip: You can also place holes on reference planes if you do not have a planar face. For example, you can create a plane tangent to a cylindrical face and use it to create a hole.

The Hole Wizard creates shaped holes, such as countersunk and counterbore types. The process creates two sketches. One defines the shape of the hole. The other, a point, locates the center.
• From the Insert menu choose **Features, Hole, Wizard**
• Or choose the **Hole Wizard** tool on the Features toolbar

16. **Hole Position**
   Again, an existing face of the model will be used to position geometry. Select the face indicated and **Insert, Features, Hole, Wizard** ...

17. **Click the Counter bore Hole Type**
   Set the properties of the hole as follows:
   - **Standard**: ANSI Inch
   - **Screw Type**: Hex Bolt
   - **Size**: ¼
   - **End Condition**: Through All

18. **Hole Placement (Positions Tab)**
   This portion of the wizard is used to locate and define the center point of the hole. A sketch point is added as the hole center point.

   Click the **Positions Tab** in the hole wizard (click the sketch **Point** tool to turn it on if not already selected).

   **Tip**: Multiple instances of the hole can be created in one command by inserting additional points at other locations.

19. **Wake up the Centerpoint**
   Select the point and drag it onto the circumference of the large arc. Do not drop it. When the **Coincident** symbol appears, the center point of the large arc has been “woken up” and is now a point you can snap to.

   Now drag the point onto the arc’s centerpoint. Look for the feedback that tells you that you are snapping to the arc’s center, a coincident relation.

   Drop the point onto the centerpoint by releasing the mouse button.

20. **Completed Hole**
   Click **Finish** (the green checkmark) to complete the hole feature
Cut Feature

Once the two main boss features are completed, it is time to create a cut to represent the removal of material. Cut features are created in the same way as bosses in this case with a sketch and extrusion.

The menu for creating a cut feature by extruding is identical to that of creating a boss. The only difference is that a cut removes material while a boss adds it. Other than that distinction, tile commands are the same. This cut represents a slot.

- From the Insert menu select Cut, Extrude....
- Or on the Features toolbar, choose Extruded Cut.

21. Rectangle
Press the spacebar and double-click* Front. Start a sketch on this large face and add a rectangle Coincident with the bottom model edge.

Note: When selecting multiple objects, hold down the Ctrl key and then select the objects.

22. Relations
Select the left vertical sketch line and the vertical model edge. Add a Collinear relation between them. Repeat the process on the opposite side.

23. Dimension
Add a dimension to fully define the sketch. Change the view orientation to Isometric.

24. Through All Cut
Click Insert, Cut, Extrude or pick the Extruded Cut tool on the Features toolbar, Choose Through All and click OK. This type of end condition always cuts through the entire model no matter how far. No depth setting was needed. Rename the feature BottomSlot.
Other Holes
Two other holes are required in this model. Using the top face of the first feature, two hole features can be created at once.

25. Change the View Orientation
Click the top tool on the Standard Views toolbar as an alternate method of changing view orientation. Select the top, flat face of the first feature.

26. Hole
Click the hole tab and set the properties of the hole as follows:

- **Standard**: ANSI Inch
- **Screw Type**: All Drill sizes
- **Size**: 9/32
- **End Condition**: Through All

27. Locations Tab
The Point tool is active. Click a second location on the left side of the face.

28. Dimensions
Add dimensions as shown. The left point remains under defined.

29. Horizontal Relation
Select both points and add a Horizontal relation ( ) between them. If done correctly the sketch will labeled as “Fully Defined” and again shown in the bottom right hand corner of the screen (Figure 3).

30. Return to a Isometric View
View Options

SolidWorks gives you the option of representing your solid models in one of several different ways. They are listed below with their icons.

- Shaded
- Shaded with Edges
- Hidden Lines Removed
- Hidden Lines Visible
- Wireframe

![Shaded](image1) ![Shaded with Edges](image2) ![Hidden Lines Removed](image3) ![Hidden Lines Visible](image4) ![Wireframe](image5)

Figure 21

Fillet

Filleting refers to both fillets and rounds. The distinction is made by the geometric conditions, not the command itself. Fillets are created on selected edges. Those edges can be selected in several ways. Options exist for fixed or variable radius fillets and tangent edge propagation. Both fillets (adding volume) and rounds (removing volume) are created with this command. The orientation of the edge or face determines which is used. Some general filleting rules are:

1. Leave cosmetic fillets until the end.
2. Create multiple fillets that will have the same radius in the same command.
3. When you need fillets of different radii, generally you should make the larger fillets first.
4. Fillet order is important. Fillets create faces and edges that can be used to generate more fillets.

- From the Insert menu, select Feature, Fillet/Round....
- Pick the tool ![Fillet icon](image6) on the Features toolbar

31. Insert Fillet

Select the Fillet option in one of the ways mentioned above. The Fillet options appear in the Property Manager.

- Set the radius value = 0.25”

You have a choice between Full preview, Partial preview and No preview of the fillet. Full preview generates a mesh preview on each selected edge. Partial preview only generates the preview on the first edge you select.

Tip: The display can be changed to Hidden Lines Visible to make it easier to select the edges. The edges can be selected “through” the shaded model as well.
32. Edge selection
The edges will highlight red as the cursor moves over them and then appear green as they are selected. Look for the cursor indicating that you are selecting an edge not a face. A callout appears on the first edge you select. **Select all the edges highlighted in yellow shown below in the hidden line view (Figure 22).**

![Figure 22](image.png)

![Figure 23](image.png)

You can customize the colors of the SolidWorks user interface. For example, you can change the dynamic highlight color from red to some other color. This is done through Tools, Options, System Options, Colors. You can select predefined color schemes, or create your own. In some cases, we have altered colors from their default settings to improve clarity and reproduction quality. As a result the colors on your system may not match the colors used in this book.

**Tip:** You can also select edges using a window. Using the left mouse Button, drag a window surrounding one or more edges. Edges that are entirely inside the window are selected.

33. Completed fillets
All six fillets are controlled by the same dimension value. The creation of these fillets has generated new edges suitable for the next series of fillets shown above in the grey shaded figure.

34. Recent Commands Menu
SolidWorks provides a “just used” buffer that lists the last few commands for easy reuse.

**Recent Command**
Right-click in the graphics window and select Recent Commands and Fillet command from the dropdown list to use it again.
**Fillet Propagation**

A selected edge that connects to others in a smooth fashion (through tangent curves) can propagate a single selection into many.

35. **Preview and Propagate**

Add another filet, radius=0.125”, using **Full preview**. Select the edges indicated in yellow to see the selected edges and preview. A callout only appears on the first edge you select.

36. **Additional selections**

Select the inner arc edge to see another preview with propagation. A callout only appears on the first edge you select.

37. **Last selection**

Select one final edge to complete the fillet. More propagation occurs due to the connections between the edges. All selections should yield a part similar to Figure 24. Click OK when all selections have been made. Upon successful completion the part should resemble Figure 25.

![Figure 24](image1.png)

![Figure 25](image2.png)